100 Important Questions On IBM AIX For Interview
Q – 1 What is VGDA?
Ans- Volume Group Descriptor Area. It contains the information about volume group to which the physical volume belongs to. It also contains the information about physical partitions, logical partitions and logical volumes.
Q – 2 What is the login process to the AIX system?
Ans- ★ AIX is a multi-user system
★ When the user login he needs to provide the user name and password for authentication purposes.
★ After the successful login, AIX starts the SHELL program.
Q – 3 What is SHELL program?
Ans- ☆ As the user login to the AIX server, the AIX starts the SHELL program.
☆ The SHELL is a command interpreter.
☆ It takes the inputs from the users and executes it.
☆ SHELL is not only the command interpreter it also provide great flexibility to the user.
☆ SHELL not only read and execute the commands it also read the files written in the form of programs and executes them, these shell program files are known as SHELL scripts. The extension of SHELL script is .sh.
Q – 4 List the advantages of Bourne Again Shell or bash?
Ans- ☛ Bash is the GNU shell
☛ Bash is an sh-compatible shell that incorporates useful features from the Korn shell (ksh) and C shell (csh).
☛ It is intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools standard.
☛ It offers functional improvements over sh for both programming and interactive uses.
☛ Interactive usage includes command line editing, unlimited size command history, job control, shell functions and aliases, indexed arrays of unlimited size, and integer arithmetic in any base from two to sixty-four. Bash can run most sh scripts without modification.
Q – 5 Explain the various SHELL types?
Ans- ☷ sh or Bourne Shell
☷ bash or Bourne Again shell
☷ csh or C shell
☷ tcsh or Turbo C shell
☷ ksh or the Korn shell
Q – 6 What is VGSA in AIX?
Ans- Volume Group Status Area it contains the information about physical partition from all physical volumes of the same volume group. It contains the status of VG.
Q – 7 How to lock a user’s account?
Ans- #chuser account_lock=true username
Q – 8 How do u take backup of file systems?
Ans- #backup -f /dev/rmt0
Q – 9 What command to restore backup of non – rootvg?
Ans- # restvg -x -d -f /dev/rmt0
Q – 10 What command to take backup other vg’s?
Ans- # savevg -if /dev/rmt0 /vgname
Q – 11 How will u append a file to a previous archive take by Tar?
Ans- #tar -rvf /dev/rmt0
Q – 12 How will u restore a file from already take backup using backup?
Ans- #restore -xvqf /dev/rmt0
Q – 13 How to unlock user account?
Ans- chuser -a account=true username
Q – 14 What are the types of installation in AIX?
Ans-New and complete overwrite
Migration
Preservation
Q – 15 What are the types of ODM Database?
Ans- Pre-defined database PdDv, PdAt
Customised database CuDv, CuAt
Q – 16 How to remove a failed package installation?
Ans- #installp -C
Q – 17 How do you find history of a file set?
Ans- #lslpp -h
Q – 18 How will you check whether software is installed or not?
Ans- # lslpp -L |grep -i (software_name)
Q – 19 How will you reject a committed fileset?
Ans- # installp -r -g fileset name
Q – 20 What is the latest OS level?
Ans- #oslevel -rq
Q – 21 What are the two states of installation?
Ans- Applied and commit state
In applied state if want to do any changes on installed software then we can do.
But in commit the changes are not allowed to do. Once did installation.
A committed fileset update cannot be rejected.
Output from the installp -s command, which is used to get a list of applied software fileset updates and updates that are available to be either committed or rejected.
Q – 22 Types of VG & explain about them?
Ans- Normal vg -32 pv, 256 lv
# mkvg -y normvg -s 128 hdisk4
Big vg :- 128pv,512lv
# mkvg -B -y bigvg -s 128 hdisk9
Scalable vg: -1024pv, 4096 lv
mkvg -S -y scalvg -s 512 hdisk1
Q – 23 How many VGs can be created in a LVM?
Ans- 255 any no. of vg can create.
Q – 24 How to change a 32 bit kernel to 64 bit kernel?
Ans- To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX 5.1 or AIX 5.2levels.
# bootinfo -y
It shows a kernel is either 32-bit or 64-bit.
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX 5.1 or AIX 5.2levels.
# bootinfo -y
It shows a kernel is either 32-bit or 64-bit.
To change to a 64-bit kernel, enter the following commands:
# ln -sf /usr/lib/boot/unix_64 /unix
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr
Q – 25 How to change a 64 bit kernel to 32 bit kernel?
Ans- ☛ Modify the /usr/lib/boot/unix directory and the /unix directory to be a symbolic link to the binary for the desired kernel.
☛ Run the bosboot command to write a new system boot image.
☛ Reboot the system.
The path name of the 64-bit kernel is /usr/lib/boot/unix_64, and the
path name of the multiprocessor versions of the 32-bit kernel is
/usr/lib/boot/unix_mp.
☛ # ln -sf /usr/lib/boot/unix_mp /unix
☛ # ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
☛ # lslv -m hd5
☛ # bosboot -ad /dev/ipldevice
☛ # shutdown -Fr
☛ # bootinfo -K (should now be 32)
Q – 26 How will you check whether a device is installed or not?
Ans- # lsdev -Cc disk
Q – 27 Two states of device availability and explain them?
Ans- Available state and defined state. When device is in defined state it means it cannot use. Not in ready state. Run cfgmgr try to make available known in the system that device. Available state means that device is ready to use
# lsdev -Cc disk
It displays which disks are available
Q – 28 Which file that error daemon stay?
Ans- /usr/lib/errdemon
Q – 29 When does error demon start in boot process?
Ans- rc.boot phase 3
Q – 30 What is the command to clear the errorlog?
Ans- # errclear
Q – 31 What is the command to see the error log?
Ans- # errpt -a
# errpt -d H [H/W]
# errpt -d S [S/W]
Q – 32 What are the error levels severity?
Ans-permanent
Temporary
Informational
Unknown.
Q – 33 What are the types of error?
Ans-H/W error
S/W error
Operator error
Unknown error.
Q – 34 How to enable & disable quorum?
Ans- # chvg -vy pv_name
# chvg -vn pv_name
#chvg -Qn vgname
#chvg -Qs vgname
Q – 35 What will you do if a disk gets failed?
Ans- diag command
Q – 36 What is major number?
Ans- A major number refers to a type of device. A device number is a major number, and a minor number specifies a particular device of that type or sometimes the operation mode of that device type.
Q – 37 How will you rename a VG?
Ans- ☆ Unmount all filesystems in VG.
☆ # umount /test (mount point name)
☆ #varyoffvg datavg
☆ #exportvg datavg0
☆ Importvg with new name
☆ # importvg -y newvg hdisk4
Q – 38 What is the default PP Size in AIX?
Ans- 128MB
Q – 39 What is T – Factor?
Ans- T – factor means that it will change the pp size to increase the efficiency of vg
#chvg -t16 datavg
Cal-if suppose that datavg pp size is 1016 we can take t factor is 16 then it comes to 2048 and pv contains in vg is 2.
Q – 40 How will you change a PP size?
Ans- PP size can be changed using a T-factor. If not then add a partitions in VG by adding one disk.
# chvg -t3 rootvg
Q – 41 How will you unmirror a VG if a PV gets failed?
Ans- First check the blv record using,
# bootlist -m normal -o
Remove the old blv record, using
# chpv -c hdisk2
# bootlist -m normal hdisk1
# bootlist -m normal hdisk2
Now unmirrorvg
# unmirrorvg rootvg hdisk2
# reducevg rootvg hdisk2
#lsvg -p rootvg
# lspv
# bootlist -m normal -o
Q – 42 What is mirroring concept?
Ans- Check disk size belong to vg , take two same size disk to mirror
# bootinfo -s hdisk2
#lsvg -p rootvg
Add one more disk of same size of already have disk having rootvg.
# extendvg rootvg hdisk2
# lsvg -p rootvg
Now mirror vg with background sync LV. It sync LVs in background with new LVs
# mirrorvg -s rootvg
Create a boot image
# bosboot -ad /dev/hdisk2
#bosboot -ad /dev/hdisk1
Add a blv
record of newly added disk, first check and then add.
# bootlist -m normal -o
#bootlist -m normal hdisk2 hdisk1
Q – 43 How to copy a LV from one VG to another?
Ans- # cplv -v
Q – 44 How will you find whether a quorum is up or not?
Ans- # lsvg vg name
Q – 45 How will you change LTG size?
Ans- #rmdev -l hdiskx
#chdev -l hdiskx -a max_transfer=0*80000
#mkdev -l hdiskx
Q – 46 How will you find LTG size?
Ans- #lsvg vgname
#lquerypv -M hdiskname
Q – 47 How will you find the inode number?
Ans- # ls -li
# istat /etc/passwd
Q – 48 What is JFS2?
Ans- ★ Can create a large size filesystems.
★ Files can be access accordingly as required. (not randomly or sequentially)
★ Max files system size=4PB
★ Max file size=4PB
★ Inode size=512
Q – 49 What is JFS?
Ans- ★ JFS is normal filesystem. We cannot create large files in JFS.
★ Files can be access dynamically.
★ Max file system size=1TB
★ Max file size=64GB
★ Inode size=128b
Q – 50 How will you create a file if a disk is given to you?
Ans- ☛ #mkvg -y datavg -s 128 hdisk1 (pv name)
☛ #mklv -y datalv -t jfs2 datavg 1
☛ #crfs -v jfs2 -d datalv -g datavg -a size=10M -m /fs1
Q – 51 How do I display routing table, interface and protocol information?
Ans- To display routing table information for an Internet interface, type netstat -r -f inet. To display interface information for an Internet interface, type netstat -i -f inet. To display statistics for each protocol, type netstat -s -f inet.
Q – 52 What is software RAID Levels do?
Ans- Redundant Arrays of Independent Disks (RAID) is formally defined as a method to store data on any type of disk medium.
Q – 53 What is logical volume manager(LVM) means?
Ans- The set of operating system commands, library subroutines and other tools that allow you to establish and control logical volume storage is called the Logical Volume Manager (LVM).
Q – 54 What is nmon tool do?
Ans- The nmon tool is designed for AIX and Linux performance specialists to use for monitoring and analyzing performance data, including:
✫ CPU utilization
✫ Memory use
✫ Kernel statistics and run queue information
✫ Disks I/O rates, transfers, and read/write ratios
✫ Free space on file systems
✫ Disk adapters
✫ Network I/O rates, transfers, and read/write ratios
✫ Paging space and paging rates
✫ CPU and AIX specification
✫ Top processors
✫ IBM HTTP Web cache
✫ User-defined disk groups
✫ Machine details and resources
✫ Asynchronous I/O – AIX only
✫ Workload Manager (WLM) – AIX only
✫ IBM TotalStorage Enterprise Storage Server (ESS) disks – AIX only
✫ Network File System (NFS)
✫ Dynamic LPAR (DLPAR) changes – only pSeries p5 and OpenPower for either AIX or Linux
Also included is a new tool to generate graphs from the nmon output and create .gif files that can be displayed on a Web site.
Q – 55 Explain a little about Vital Product Data?
Ans- VPD in AIX and Linux is a collection of configuration and informational data associated with a particular set of hardware or software. VPD refers to a subset of database tables in the Object Data Manager (ODM), Therefore the VPD and ODM terms are sometimes referred to interchangeably.
Vital product data (VPD) stores information such as part numbers, serial numbers, and engineering change levels from the Customized VPD object class or platform specific areas, not all devices contain VPD data.
Q – 56 What information is stored in object data manager?
Ans- It is a database of system and device configuration information integrated into IBM’s AIX operating system. The ODM is unique to AIX compared to other UNIX operating systems.
Example of information stored in the ODM database are:
☆ Network configuration
☆ Logical volume management configuration
☆ Installed software information
☆ Devices that AIX has drivers for
☆ Logical devices or software drivers
☆ Physical hardware device installed
☆ Menus, screens and commands that SMIT uses
Q – 57 What is RMC?
Ans- The Resource Monitoring and Control (RMC) subsystem is the scalable backbone of RSCT that provides a generalized framework for managing resources within a single system or a cluster. Its generalized framework is used by cluster management tools to monitor, query, modify, and control cluster resources.
RMC provides a single monitoring and management infrastructure for both RSCT peer domains and management domains. RMC can also be used on a single machine, enabling you to monitor and manage the resources of that machine. However, when a group of machines, each running RMC, are clustered together, the RMC framework allows a process on any node to perform an operation on one or moreresources on any other node in the domain.
Q – 58 What is kernel?
Ans- The kernel is the essential center of a computer operating system, the core that provides basic services for all other parts of the operating system. A synonym isnucleus. A kernel can be contrasted with a shell, the outermost part of an operating system that interacts with user commands. Kernel and shell are terms used more frequently in UNIX operating systems than in IBM mainframe or Microsoft Windows systems.
Typically, a kernel (or any comparable center of an operating system) includes an interrupt handler that handles all requests or completed I/O operations that compete for the kernel’s services, a scheduler that determines which programs share the kernel’s processing time in what order, and a supervisor that actually gives use of the computer to each process when it is scheduled.
A kernel may also include a manager of the operating system’s address spaces in memory or storage, sharing these among all components and other users of the kernel’s services. A kernel’s services are requested by other parts of the operating system or by application programs through a specified set of program interfaces sometimes known as system calls.
Q – 59 Explain hardware management console?
Ans- The HMC is a server or stand alone machine that provides a graphical user interface tool to manage several Power Systems. The HMC manages system through hypervisor and operating system. From version 7 it is truly web based and you can configure, installs and manage, partitioned, virtualization most of your Power5 and 6 boxes via HMC.
There are many tasks you can do with HMC, such as:
☛Powering off and on of the partition
☛Configure and activate resources to the system
☛Creates and stores LPAR profiles and allocated resources to them.
☛HMC do the dynamic memory reconfiguration of the partition.
☛Setup VIO server and VIO client thru HMC and do micro-partition, create storage
☛pool and processor pool with it
☛Provide virtual console to the partition
Most of the time we installed dual HMC for redundancy and make sure to achieve more uptime in a wide system
Q – 60 What is Capacity on Demand?
Ans- Capacity on Demand (CoD) encompasses the various capabilities for you to dynamically activate one or more resources on your server as your business peaks dictate. You can activate inactive processors or memory units that are already installed on your server on a temporary and permanent basis.
Usually, the Capacity on Demand is used for IBM System i5 and eServer i5 and IBM System p5 and eServer p5 520, 550, 570, 590, and 595 models. Some servers include a number of active and inactive resources. Active processors and active memory units are resources that are available for use on your server when it comes from the manufacturer. Inactive processors and inactive memory units are resources that are included with your server but are not available for use until you activate them.
Q – 61 How do you you get rid of a disk that is no longer really in the VG?
Ans- In this case, you DON’T want to do an exportvg. What you want to do is tell the system you want to cut out the memory of the old, bad disk from the RS/6000 AND from the VGDA of the volume group.
You simply do: reducevg -d -f or if the hdname can’t be found:
reducevg -d -f
Be careful with this command. Unlike the exportvg command, actions done
with this command WILL affect the VGDA information on the platter.
Q – 62 What do you know about TCPDump?
Ans- TCPdump is a common computer network debugging tool that runs under the command line. It allows the user to intercept and display TCP/IP and other packets being transmitted or received over a network to which the computer is attached. Tcpdump works on most Unix-like platforms: Linux, Solaris, BSD, Mac OS X, HP-UX and AIX among others. On Windows, WinDump can be used; it’s a port of tcpdump to Windows.
You must have a root or super user authority to use TCPdumps in UNIX like envrionment.
Q – 63 What does SNMP stands for?
Ans- Short for Simple Network Management Protocol, a set of protocols for managing complex networks. SNMP works by sending messages, called Protocol Data Units, to different parts of a network. SNMP-compliant devices, called Agents, store data about themselves in Management Information Bases and return this data to the SNMP requesters.
Q – 64 Explain DHCP and its uses to an environment?
Ans- Short for Dynamic Host Configuration Protocol, a protocol for assigning dynamic IP addresses to devices on a network. With dynamic addressing, a device can have a different IP address every time it connects to the network. In some systems, the device’s IP address can even change while it is still connected. DHCP also supports a mix of static and dynamic IP addresses.
Dynamic addressing simplifies network administration because the software keeps track of IP addresses rather than requiring an administrator to manage the task. This means that a new computer can be added to a network without the hassle of manually assigning it a unique IP address. Many ISPs use dynamic IP addressing for dial-up users.
Q – 65 Do you have any idea about NAT?
Ans- Short for Network Address Translation, an Internet standard that enables a local-area network (LAN) to use one set of IP addresses for internal traffic and a second set of addresses for external traffic. A NAT box located where the LAN meets the Internet makes all necessary IP address translations.
NAT serves three main purposes:
☛ Provides a type of firewall by hiding internal IP addresses
☛ Enables a company to use more internal IP addresses. Since they’re used internally only, there’s no possibility of conflict with IP addresses used by other companies and organizations.
☛ Allows a company to combine multiple ISDN connections into a single Internet connection.
Q – 66 What is SMTP and how it works?
Ans- SMTP (Simple Mail Transfer Protocol) is a TCP/IP protocol used in sending and receiving e-mail. However, since it is limited in its ability to queue messages at the receiving end, it is usually used with one of two other protocols, POP3 or IMAP, that let the user save messages in a server mailbox and download them periodically from the server. In other words, users typically use a program that uses SMTP for sending e-mail and either POP3 or IMAP for receiving e-mail. On Unix-based systems, sendmail is the most widely-used SMTP server for e-mail. A commercial package, Sendmail, includes a POP3 server. Microsoft Exchange includes an SMTP server and can also be set up to include POP3 support.
SMTP usually is implemented to operate over Internet port 25.
Q – 67 What is NAS?
Ans- Network-attached storage (NAS) is hard disk storage that is set up with its own network address rather than being attached to the department computer that is serving applications to a network’s workstation users. By removing storage access and its management from the department server, both application programming and files can be served faster because they are not competing for the same processor resources.
The network-attached storage device is attached to a local area network (typically, an Ethernet network) and assigned an IP address. File requests are mapped by the main server to the NAS file server.
Network-attached storage consists of hard disk storage, including multi-disk RAID systems, and software for configuring and mapping file locations to the network-attached device. Network-attached storage can be a step toward and included as part of a more sophisticated storage system known as a storage area network (SAN).
NAS software can usually handle a number of network protocols, including Microsoft’s Internetwork Packet Exchange and NetBEUI, Novell’s Netware Internetwork Packet Exchange, and Sun Microsystems’ Network File System. Configuration, including the setting of user access priorities, is usually possible using a Web browser.
Q – 68 Can you describe SAN in your own word?
Ans- A storage area network (SAN) is a high-speed special-purpose network (or subnetwork) that interconnects different kinds of data storage devices with associated data servers on behalf of a larger network of users. Typically, a storage area network is part of the overall network of computing resources for an enterprise.
A storage area network is usually clustered in close proximity to other computing resources such as IBM Power5 boxes but may also extend to remote locations for backup and archival storage, using wide area network carrier technologies such as ATM or SONET .
A storage area network can use existing communication technology such as IBM’s optical fiber ESCON or it may use the newer Fibre Channel technology. Some SAN system integrators liken it to the common storage bus (flow of data) in a personal computer that is shared by different kinds of storage devices such as a hard disk or a CD-ROM player.
SANs support disk mirroring, backup and restore, archival and retrieval of archived data, data migration from one storage device to another, and the sharing of data among different servers in a network. SANs can incorporate subnetworks with network-attached storage (NAS) systems.
Q – 69 What is VPN and how it works?
Ans- A VPN is a private network that uses a public network (usually the Internet) to connect remote sites or users together. Instead of using a dedicated, real-world connection such as leased line, a VPN uses “virtual” connections routed rough the Internet from the company’s private network to the remote site or employee.
Q – 70 Can you explain the steps to mirroring rootvg in your environment?
Ans- Mirroring “rootvg” protects the operating system from a disk failure. Mirroring “rootvg” requires a couple extra steps compared to other volume groups. The mirrored rootvg disk must be bootable *and* in the bootlist. Otherwise, if the primary disk fails, you’ll continue to run, but you won’t be able to reboot.
In brief, the procedure to mirror rootvg on hdisk0 to hdisk1 is
1. Add hdisk1 to rootvg: extendvg rootvg hdisk1
2. Mirror rootvg to hdisk1: mirrorvg rootvg hdisk1 (or smitty mirrorvg)
3. Create boot images on hdisk1: bosboot -ad /dev/hdisk1
4. Add hdisk1 to the bootlist:bootlist -m normal hdisk0 hdisk1
5. Reboot to disable quorum checking on rootvg. The mirrorvg turns off quorum by default, but the system needs to be rebooted for it to take effect.
Q – 71 How do I get the IP address of my machine?
Ans- Type one of the following: ifconfig -a or host Fully_Qualified_Host_Name.
Q – 72 How can I display or set values for network parameters?
Ans- The no command sets or displays current or next boot values for network tuning parameters.
Q – 73 How do I mirror a logical volume?
Ans- mklvcopy LogicalVolumeName Numberofcopies syncvg VolumeGroupName
Q – 74 How do I replace a disk?
Ans- ✰ extendvg VolumeGroupName hdisk_new
✰ migratepv hdisk_bad hdisk_new
✰ reducevg -d VolumeGroupName hdisk_bad
Q – 75 How can I clone the rootvg?
Ans- You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1: alt_disk_copy -d hdisk1.]
Q – 76 How do I list information about logical volumes?
Ans- Run the following command to display information about the logical volume #lv1: lslv lv1.
Q – 77 How do I display all logical volumes that are part of a volume group (e,g, rootvg)?
Ans- You can display all logical volumes that are part of rootvg by typing the following command: #lsvg -l rootvg/.
Q – 78 How do I increase the size of a logical volume?
Ans- To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type extendlv lv05 3.
Q – 79 How do I create a logical volume?
Ans- #mklv -y name_of_logical_volume name_of_volume_group number_of_partition.
Q – 80 How can I change the characteristics of a volume group?
Ans- You use the chvg command to change the characteristics of a volume group.
Q – 81 How do I create a volume group?
Ans- Use the following command, where s partition_size sets the number of megabytes (MB) in each physical partition where the partition_size is expressed in units of MB from one through 1,024. (It’s one through 131,072 for AIX 5.3.)
mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
The partition_size variable must be equal to a power of two (for example: one, two, four or eight). The default value for standard and big volume groups is the lowest value to remain within the limitation of 1,016 physical partitions per physical volume. The default value for scalable volume groups is the lowest value to accommodate 2,040 physical partitions per physical volume.
Q – 82 How do I know if my volume group is normal, big, or scalable?
Ans- Run the lsvg command on the volume group and look at the value for MAX PVs. The value is 32 for normal, 128 for big and 1,024 for scalable volume group.
Q – 83 What applications work with HACMP?
Ans- All popular applications work with HACMP including DB2, Oracle, SAP, WebSphere, etc. HACMP provides Smart Assist agents to let you quickly and easily configure HACMP with specific applications. HACMP includes flexible configuration parameters that let you easily set it up for just about any application there is.
Q – 84 Does HACMP work on different operating systems?
Ans- Yes. HACMP is tightly integrated with the AIX 5L operating system and System p servers allowing for a rich set of features which are not available with any other combination of operating system and hardware. HACMP V5 introduces support for the Linux operating system on POWER servers. HACMP for Linux supports a subset of the features available on AIX 5L, however this mutli-platform support provides a common availability infrastructure for your entire enterprise.
Q – 85 Why do I need a hardware management console, anyway?
Ans- You need a HMC if you plan to:
★ Configure and manage logical partitions and partition profiles (selected models can configure LINUX partitions without a HMC).
★ Perform DLPAR (dynamic LPAR) functions.
★ Activate and manage Capacity on Demand resources.
You can also use the HMC to:
★ Perform service functions
★ Manage frames (towers), IOPs and IOAs. * Note that you cannot see below the IOA to the device level.
★ Manage system profiles (yes, you can have more than one!)
★ Power on and power down. The Service Processor is always hot if there is power to the server.
★ Activate and manage Virtualization Engine technologies.
★ 5250 emulation so you can get a console up on a i5/OS partition or a virtual terminal window for AIX or LINUX.
Q – 86 What is hardware management console?
Ans- The HMC is a server or stand alone machine that provides a graphical user interface tool to manage several Power Systems. The HMC manages system through hypervisor and operating system. From version 7 it is truly web based and you can configure, installs and manage, partitioned, virtualization most of your Power5 and 6 boxes via HMC. There are many tasks you can do with HMC, such as,
☛ Powering off and on of the partition
☛ Configure and activate resources to the system
☛ Creates and stores LPAR profiles and allocated resources to them.
☛ HMC do the dynamic memory reconfiguration of the partition.
☛ Setup VIO server and VIO client thru HMC and do micro-partition, create storage
☛ pool and processor pool with it
☛ Provide virtual console to the partition
Most of the time we installed dual HMC for redundancy and make sure to achieve more uptime in a wide system.
Q – 87 What is network information service?
Ans- NIS was developed to simplify the task of administrating a number of machines over a network. In particular was the requirement to maintain copies of common files (e.g. password, group and host) across different systems.
Q – 88 Explain network file systems?
Ans- The Network File System (NFS) is a distributed file system that allows users to access files and directories of remote servers as if they were local. Suppose, Server A, that makes its file systems, directories, and other resources available for remote access. Client’s computers, or their processes, that use a server’s resources. Export the act of making file systems available to remote clients. Mount the act of a client accessing the file systems that a server exports.
Q – 89 What is a logical partition?
Ans- A logical partition (LPAR) is the division of a computer’s processors, memory, and hardware resources into multiple environments so that each environment can be operated independently with its own operating system and applications
Q – 90 What does logical volume manager(LVM) mean?
Ans- The set of operating system commands, library subroutines and other tools that allow you to establish and control logical volume storage is called the Logical Volume Manager (LVM).
Q – 91 What is server message block file system(SMBFS) in AIX?
Ans- Server Message Block File system (SMBFS) allows access to shares on SMB servers as local file systems on AIX. In this file system, the user can create, delete, read, write, and modify the access times of files and directories. The owner or access mode of files and directories cannot be changed.
Q – 92 Define commands and process in AIX?
Ans- A command is a request to perform an operation or run a program. A process is a program or command that is actually running on the computer.We use commands to tell the operating system what task you want it to perform. When commands are entered, they are deciphered by a command interpreter (also known as a shell), and that task is processed.
The operating system can run many different processes at the same time. The operating system allows you to manipulate the input and output (I/O) of data to and from your system by using specific I/O commands and symbols. You can control input by specifying the location from which to gather data.
For example, you can specify to read input entered on the keyboard (standard input) or to read input from a file. You can control output by specifying where to display or store data. For example, you can specify to write output data to the screen (standard output) or to write it to a file.
Commands :- Some commands can be entered simply by typing one word. It is also possible to combine commands so that the output from one command becomes the input for another command.
Processes :- A program or command that is actually running on the computer is referred to as a process.
Q – 93 What are the logging in and out commands in AIX?
Ans- To login in:
Login id:
Password: To log out:
$ <ctrl+d> (or)
$ (or)
☛ AIX is designed as a multiuser system, a level of security is implemented to control access. Each user of the system has a user name and associated password (optional).
☛ If the user ID requires a password, the system will prompt for the password in a similar manner. While the user is typing a password, it does not appear on the screen.
☛ To terminate the session the user may either enter the exit or logout command, or press the key combination (holding down the Ctrl key while pressing the d key.) logout only works if you are in your login shell.
Q – 94 What are the keyboard shortcuts used on AIX terminal?
Ans- ☛ Backspace : to correct mistakes.
☛ <ctrl+c> : terminates the correct command and return to the shell.
☛ <ctrl+d> : end of transmission or end of file
☛ <ctrl+s> : temporary stops the output to the screen
☛ <ctrl+q> : resumes output which was stopped by ctrl+s
☛ <ctrl+u>: erases the entire line.
Q – 95 Explain the AIX file system?
Ans- ☛ AIX uses a hierarchical file tree that consists of directories, sub-directories and files.
☛ The top level directory is called the root (/) directory that has many sub-directories.
☛ The file tree is mounted during the system start-up.
Q – 96 How to configure a read/write optical drive by using configuration manager?
Ans- Method of Configuration Manager, searching the current configuration, detecting any new devices, and automatically configuring the devices. This method is used when little information is known about the read/write optical drive.
a)Use the configuration manager to configure all newly detected devices on the system (including the read/write optical drive) by typing:
cfgmgr
b)Type the following command to list the names, location codes, and types of all currently configured read/write optical drives:
lsdev -C -c rwoptical
c)Determine the name of the newly configured read/write optical drive using the location code that matches the location of the drive being added.
Q – 97 How to configure a read/write optical drive?
Ans- There are two methods for configuring a read/write optical drive. The read/write optical drive must be connected to the system and powered on.
☛ Method 1:-Method one is the faster of the two methods. It only configures the read/write optical drive specified.
To use this method, you must provide the following information:
Subclass Defines how the drive is attached.
Type Specifies the type of read/write optical drive.
Parent Name Specifies the system attachment the drive is connected to.
Where Connected Specifies the logical address of the drive.
Enter the following command to configure the read/write optical drive:
mkdev -c rwoptical -s Subclass -t Type -p ParentName -w WhereConnected
The following is an example of a read/write optical drive that has a SCSI ID of 6, a logical unit number of zero, and is connected to the third (scsi3) SCSI bus:
mkdev -c rwoptical -s scsi -t osomd -p scsi3 -w 6,0 -a pv=yes
Q – 98 What are the unique features of AIX?
Ans- The following are some unique system management features of AIX.
☛ Logical Volume Manager :- The Logical Volume Manager (LVM) maintains the hierarchy of logical structures that manage disk storage.
☛ System Resource Controller:- The System Resource Controller (SRC) provides a set of commands and subroutines for creating and controlling subsystems and is designed to minimize the need for human intervention in system processing.
☛ Object Data Manager :- The Object Data Manager (ODM) is a data manager intended for the storage of system data.
☛ Software Vital Product Data:- Certain information about software products and their installable options is maintained in the Software Vital Product Data (SWVPD) database.
☛ Workload management :- Workload Manager (WLM) is designed to provide the system administrator with increased control over how the scheduler virtual memory manager (VMM) and the disk I/O subsystem allocate resources to processes. You can use WLM to prevent different classes of jobs from interfering with each other and to allocate resources based on the requirements of different groups of users.
☛ Operating system updates:- The operating system package is divided into file-sets, where each file-set contains a group of logically related customer deliverable files. Each file-set can be individually installed and updated.
Q – 99 What is System Management Interface Tool (SMIT)?
Ans- SMIT is the System Management Interface Tool for AIX. It allows a user to navigate a menu hierarchy of commands, rather than using the command line. Invocation is typically achieved with the command smit.
Experienced system administrators make use of the F6 function key which generates the command line that SMIT will invoke to complete the proposed task. SMIT also generates a log of commands that are performed in the smit.script file. The smit.script file automatically records the commands with the command flags and parameters used.
The smit.script file can be used as an executable shell script to rerun system configuration tasks. SMIT also creates the smit.log file, which contains additional detailed information that can be used by programmers in extending the SMIT system.
Q – 100 What is IBM AIX?
Ans- AIX(Advanced Interactive executive) is a series of proprietary Unix operating systems developed and sold by IBM for several of its computer platforms. Originally released for the IBM 6150 RISC workstation, AIX now supports or has supported a wide variety of hardware platforms, including the IBM RS/6000 series and later IBM POWER and PowerPC-based systems, IBM System i, System/370 mainframes, PS/2 personal computers, and the Apple Network Server. AIX is based on UNIX System V with 4.3BSD-compatible extensions. It is one of four commercial operating systems that are presently certified to The Open Group’s UNIX 03 standard (The others are Mac OS X, Solaris and HP-UX.)
Q – 101 Can you please explain the file types in AIX?
Ans- A file is a collection of data, stream of characters or a byte stream. No structure is imposed on the file by OS.
The various file types are as follows:
• Ordinary (text or code data)
• Directory (table of contents, that stores a list of files within that directory)
• Special files(representing hardware or logical devices)
An ordinary file can contain either text or code data. Text files are readable by a user and can be displayed or printed. Code data, also known as a binary file is readable by the computer.
Binary files may be executable. Directories contain information the system needs to access all types of files, but they do not contain the actual data. Each directory entry represents either a file or a subdirectory.Special files usually represent devices used by the system.
Q – 102 Give the brief about man command?
Ans- The man command will look in the on-line manual for information on the commands, subroutines and files with the name title. This information will be presented on the screen one page at a time for the user to browse.
The information consists of:
PURPOSE : The title and a one-line description of the command
SYNTAX : The syntax of the command
DESCRIPTION : Many pages of information about the function and usage of the command with examples
FLAGS : Description of available options
FILES : Any system files associated with the command
RELATED INFO : The names of any related commands
BUGS : Any information about the behavior/performance of the command in unusual circumstances $ man
Q – 103 Write the key board shortcuts used on AIX terminal?
Ans- • Backspace : to correct mistakes.
• <ctrl+c> : terminates the correct command and return to the shell.
• <ctrl+d> : end of transmission or end of file
• <ctrl+s> : temporary stops the output to the screen
• <ctrl+q> : resumes output which was stopped by ctrl+s
• <ctrl+u>: erases the entire line.
Q – 104 Write clear, echo, print and banner command?
Ans-
• Clear: clears the terminal signal
• echo : Writes what follows to the screen.
• $ echo Lunch is at 12:00
• Banner : Writes character strings in large letters to the screen
Q – 105 Write the date and calendar command?
Ans- • $ date
Q – 106 Explain the advantages of Bourne Again Shell or bash?
Ans- • Bash is the GNU shell
• It is intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools standard.
• It offers functional improvements over sh for both programming and interactive uses.
• Interactive usage includes command line editing, unlimited size command history, job control, shell functions and aliases, indexed arrays of unlimited size, and integer arithmetic in any base from two to sixty-four. Bash can run most sh scripts without modification.
Q – 107 Name the various SHELL types?
Ans- • sh or Bourne Shell
• bash or Bourne Again shell
• csh or C shell
• tcsh or Turbo C shell
• ksh or the Korn shell
Q – 108 Explain the SHELL program?
Ans- • As the user login to the AIX server, the AIX starts the SHELL program.
• The SHELL is a command interpreter.
• It takes the inputs from the users and executes it.
• SHELL is not only the command interpreter it also provide great flexibility to the user.
• SHELL not only read and execute the commands it also read the files written in the form of programs and executes them, these shell program files are known as SHELL scripts. The extension of SHELL script is .sh.
Q – 109 Explain the login process to the AIX system?
Ans- • AIX is a multi-user system
• When the user login he needs to provide the user name and password for authentication purposes.
• After the successful login, AIX starts the SHELL program.
Q – 110 Give the brief about AIX?
Ans- • AIX is the IBM product.
• It is the multi user Operating System.
• AIX control these hardware devices and to share them between multiple users, for this purpose it uses the AIX Kernel System.
• AIX OS servers are the IBM servers used in all over the world.
• Kernel is loaded during the system startup.
• Kernel is the heart of the AIX OS.
• Kernel controls the various processes and tasks.
Q – 111 Write the command format in AIX format?
Ans- • $ command option(s) argument(s)
• Mail –f newmail
• The command or process name should come first.
• The options should follow the command name, separated by a space, and preceded by a minus sign (-). Multiple options may be grouped immediately after a single minus sign or separated by spaces and each preceded by a minus sign.
Q – 112 Write the password change command?
Ans- • $ passwd
$ old password:
$ new password:
$ Enter the new password again:
• The passwd command is used to change the user password.
• The system will start the passwd process which will prompt the user for their old password first. To prevent users being locked out of the system the new password is entered twice.
Q – 113 Write the logging in and Out commands in AIX?
Ans- • To login in:
Login id:
Password: • To log out:
$ <ctrl+d> (or)
$ (or)
$ logout
• AIX is designed as a multiuser system, a level of security is implemented to control access. Each user of the system has a user name and associated password (optional).
• If the user ID requires a password, the system will prompt for the password in a similar manner. While the user is typing a password, it does not appear on the screen.
• To terminate the session the user may either enter the exit or logout command, or press the key combination (holding down the Ctrl key while pressing the d key.) logout only works if you are in your login shell.
Q – 114 What is AIX file system?
Ans- • AIX uses a hierarchical file tree that consists of directories, subdirectories and files.
• The top level directory is called the root (/) directory that has many subdirectories.
• The file tree is mounted during the system startup.
Q – 115 What is an interactive shell?
Ans- An interactive shell generally reads from, and writes to, a user’s terminal: input and output are connected to a terminal. Bash interactive behavior is started when the bash command is called upon without non-option arguments, except when the option is a string to read from or when the shell is invoked to read from standard input, which allows for positional parameters to be set.